请稍等 ...
×

采纳答案成功!

向帮助你的同学说点啥吧!感谢那些助人为乐的人

安装./requirements.txt文件报错

回答2 浏览105 2020-10-12 17:12:11

使用pip 安装 requirements.txt 报错

pipenv install -r ./requirements.txt                                                        
Requirements file provided! Importing into Pipfile…
Pipfile.lock not found, creating…
Locking [dev-packages] dependencies…
Locking [packages] dependencies…
Building requirements...
Resolving dependencies...
✘ Locking Failed!
[pipenv.exceptions.ResolutionFailure]: Warning: Your dependencies could not be resolved. You likely have a mismatch in your sub-dependencies.
  First try clearing your dependency cache with $ pipenv lock --clear, then try the original command again.
 Alternatively, you can use $ pipenv install --skip-lock to bypass this mechanism, then run $ pipenv graph to inspect the situation.
  Hint: try $ pipenv lock --pre if it is a pre-release dependency.
ERROR: Could not find a version that matches django<2.0.0,==1.8.2,>=1.8,>=1.9.0 (from -r /var/folders/1f/c2gv4y2j3xj38mcgv4rjx8sr0000gn/T/pipenv6v0rzmtfrequirements/pipenv-ydAjjt-constraints.txt (line 62))
Tried: 1.1.3, 1.1.4, 1.2, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.2.7, 1.3, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.4, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.5, 1.4.6, 1.4.7, 1.4.8, 1.4.9, 1.4.10, 1.4.11, 1.4.12, 1.4.13, 1.4.14, 1.4.15, 1.4.16, 1.4.17, 1.4.18, 1.4.19, 1.4.20, 1.4.21, 1.4.22, 1.5, 1.5.1, 1.5.2, 1.5.2, 1.5.3, 1.5.4, 1.5.5, 1.5.6, 1.5.7, 1.5.8, 1.5.8, 1.5.9, 1.5.10, 1.5.11, 1.5.12, 1.5.12, 1.6, 1.6, 1.6.1, 1.6.1, 1.6.2, 1.6.2, 1.6.3, 1.6.3, 1.6.4, 1.6.4, 1.6.5, 1.6.5, 1.6.6, 1.6.6, 1.6.7, 1.6.7, 1.6.8, 1.6.8, 1.6.9, 1.6.9, 1.6.10, 1.6.10, 1.6.11, 1.6.11, 1.7, 1.7, 1.7.1, 1.7.1, 1.7.2, 1.7.2, 1.7.3, 1.7.3, 1.7.4, 1.7.4, 1.7.5, 1.7.5, 1.7.6, 1.7.6, 1.7.7, 1.7.7, 1.7.8, 1.7.8, 1.7.9, 1.7.9, 1.7.10, 1.7.10, 1.7.11, 1.7.11, 1.8, 1.8, 1.8.1, 1.8.1, 1.8.2, 1.8.2, 1.8.3, 1.8.3, 1.8.4, 1.8.4, 1.8.5, 1.8.5, 1.8.6, 1.8.6, 1.8.7, 1.8.7, 1.8.8, 1.8.8, 1.8.9, 1.8.9, 1.8.10, 1.8.10, 1.8.11, 1.8.11, 1.8.12, 1.8.12, 1.8.13, 1.8.13, 1.8.14, 1.8.14, 1.8.15, 1.8.15, 1.8.16, 1.8.16, 1.8.17, 1.8.17, 1.8.18, 1.8.18, 1.8.19, 1.8.19, 1.9, 1.9, 1.9.1, 1.9.1, 1.9.2, 1.9.2, 1.9.3, 1.9.3, 1.9.4, 1.9.4, 1.9.5, 1.9.5, 1.9.6, 1.9.6, 1.9.7, 1.9.7, 1.9.8, 1.9.8, 1.9.9, 1.9.9, 1.9.10, 1.9.10, 1.9.11, 1.9.11, 1.9.12, 1.9.12, 1.9.13, 1.9.13, 1.10, 1.10, 1.10.1, 1.10.1, 1.10.2, 1.10.2, 1.10.3, 1.10.3, 1.10.4, 1.10.4, 1.10.5, 1.10.5, 1.10.6, 1.10.6, 1.10.7, 1.10.7, 1.10.8, 1.10.8, 1.11, 1.11, 1.11.1, 1.11.1, 1.11.2, 1.11.2, 1.11.3, 1.11.3, 1.11.4, 1.11.4, 1.11.5, 1.11.5, 1.11.6, 1.11.6, 1.11.7, 1.11.7, 1.11.8, 1.11.8, 1.11.9, 1.11.9, 1.11.10, 1.11.10, 1.11.11, 1.11.11, 1.11.12, 1.11.12, 1.11.13, 1.11.13, 1.11.14, 1.11.14, 1.11.15, 1.11.15, 1.11.16, 1.11.16, 1.11.17, 1.11.17, 1.11.18, 1.11.18, 1.11.20, 1.11.20, 1.11.21, 1.11.21, 1.11.22, 1.11.22, 1.11.23, 1.11.23, 1.11.24, 1.11.24, 1.11.25, 1.11.25, 1.11.26, 1.11.26, 1.11.27, 1.11.27, 1.11.28, 1.11.28, 1.11.29, 1.11.29
Skipped pre-versions: 1.8a1, 1.8b1, 1.8b2, 1.8rc1, 1.9a1, 1.9b1, 1.9rc1, 1.9rc2, 1.10a1, 1.10a1, 1.10b1, 1.10b1, 1.10rc1, 1.10rc1, 1.11a1, 1.11b1, 1.11rc1, 1.11rc1
There are incompatible versions in the resolved dependencies:
  django==1.8.2 (from -r /var/folders/1f/c2gv4y2j3xj38mcgv4rjx8sr0000gn/T/pipenv6v0rzmtfrequirements/pipenv-ydAjjt-constraints.txt (line 62))
  django<2.0.0,>=1.9.0 (from xadmin==0.6.1->-r /var/folders/1f/c2gv4y2j3xj38mcgv4rjx8sr0000gn/T/pipenv6v0rzmtfrequirements/pipenv-ydAjjt-constraints.txt (line 53))
  django>=1.8 (from django-crontab==0.7.1->-r /var/folders/1f/c2gv4y2j3xj38mcgv4rjx8sr0000gn/T/pipenv6v0rzmtfrequirements/pipenv-ydAjjt-constraints.txt (line 17))
  django>=1.8 (from django-formtools==2.1->-r /var/folders/1f/c2gv4y2j3xj38mcgv4rjx8sr0000gn/T/pipenv6v0rzmtfrequirements/pipenv-ydAjjt-constraints.txt (line 59))

添加回答

2回答

Python+Django+Ansible Playbook自动化运维项目实战

难度中级
时长15小时
人数765
好评度98.1%

【课程代码升级3.6版本】阿里大牛全面践行DevOps,带你开启运维与开发间高效协作模式!

讲师

Jeson Python工程师

互联网公司技术负责人、架构师,同时于多家企业兼任技术指导。曾任职于凤凰网,阿里文娱任职python开发、曾就职于阿里妈妈任职资深系统工程师。

意见反馈 帮助中心 APP下载
官方微信