请稍等 ...
×

采纳答案成功!

向帮助你的同学说点啥吧!感谢那些助人为乐的人

dash-board 转发失败的原因找到了

回答1 浏览109 2020-10-10 09:05:46

老师:我dash-board 不能转发的原因找到了:

  1.   应该使用1.10版本的dashboard yaml file, 地址如下:

    kubectl apply -f https://raw.githubusercontent.com/kubernetes/dashboard/v1.10.1/src/deploy/recommended/kubernetes-dashboard.yaml

  2.  使用Window 的同学 在用浏览器打开dashboard的时候, 必须使用Firefox 浏览器安装SwitchyOmega 插件, 然后用Firefox 打开地址:

    http://localhost:8001/api/v1/namespaces/kube-system/services/https:kubernetes-dashboard:/proxy/

       Google 的Chrome 浏览器这里不行!!!

***

 如果同学需要安装2.0 以上 版本的dashboard yaml: 

  kubectl apply -f https://raw.githubusercontent.com/kubernetes/dashboard/v2.0.0-beta8/aio/deploy/recommended.yaml

浏览器打开的地址是:

http://localhost:8001/api/v1/namespaces/kubernetes-dashboard/services/https:kubernetes-dashboard:/proxy/

反正我没试过2.0版的yaml, 有兴趣的同学可以试试,看看行不行。

参考: https://stackoverflow.com/questions/57719573/services-kubernetes-dashboard-not-found-when-access-kubernetes-ui

  

添加回答

1回答

  • 手动点赞!祝学习愉快!

    2020-10-10 17:52:44
    • 提问者 幕布斯0328478 #1
      Tonibai 老师, 我发现上面的关于我dash-board 不能转发的原因 的帖子有误,现在根据我自己的发现做一个更正:

      上面的帖子里面的v1.10.1 版本的kubernetes-dashboard.yaml 已经不能再kubernetes v1.17以后使用了,(dashboard 登录界面 使用 token 进不去)。
      所以必须使用v2以上版本。 根据github上的dashboard 网页:https://github.com/kubernetes/dashboard
      现在使用v2.0.4版本:
       kubectl apply -f https://raw.githubusercontent.com/kubernetes/dashboard/v2.0.4/aio/deploy/recommended.yaml

      使用firefox打开url:
      http://localhost:8001/api/v1/namespaces/kubernetes-dashboard/services/https:kubernetes-dashboard:/proxy/

      然后使用token登录才能进的去。
      以上步骤经过我自己验证。
      2020-10-12 02:11:12
    • tonybai 回复 提问者 幕布斯0328478 #2
      感谢反馈!
      2020-10-15 17:37:35

Kubernetes实战 高可用集群搭建,配置,运维与应用

难度中级
时长7小时1分钟
人数698
好评度99.2%

以生产为目标,原理+操作, Kubernetes结合典型云原生应用

讲师

tonybai 全栈工程师

Tony Bai: Go程序员,C程序员,技术架构师,技术讲师/培训师,技术撰稿人。先后供职于国内某大型软件公司和某创业型数据与基础设施服务公司。喜技术,爱钻研;热爱开源;喜好写博客,写博十余年,仍孜孜不倦。目前的主要研究领域包括:Go、Kubernetes、Docker、区块链、儿童编程教育等。

意见反馈 帮助中心 APP下载
官方微信